FrostWire 4.21.8 About

FrostWire 4.21.8 will run on many Unix and Linux varieties if you have the Java Runtime Environment installed, although the installer may not work correctly.