RoboForm

RoboForm 7.6.5 works on Windows 2000, 2003, XP, Vista, 7, Server systems. Internet Explorer version 6.0 or later is required. All Service Packs and security patches must be installed.