Version History of RoboForm 6.9.95

  • Full support for Firefox 3.5, add Adapter for it to RoboForm installer.
  • Remove support for Firefox 1.5 and 2.0 from RoboForm installer, now available by XPI install only.
  • Add Sync button to RF toolbar, it controls synchronization with RoboForm Online server.
  • Fix auto-submit issues to improve logins at comcast.com and virginiagasprices.com and similar sites.
  • Improve throwing JavaScript events to better fill and submit forms.